Forums Forums (
-   Altair 680 (
-   -   Up and Running (

bugman 06-18-2008 11:16 AM

Up and Running
Well, got it running last night. Have not completed the back panel yet, or tried the terminal interface. But the main board and control board are in and I put power to the mainboard. Seems to be operating OK. Am able to observe memory locations and deposit new data. Will try a simple program tonight.

I do have one concern though that may or may not be normal. When I initially power up the mainboard, all the leds come on for a bit. Then they begin to correctly reflect the memory location and data. But the panel does not become stable for about 10-30 seconds. So to re-cap, upon power up, all leds light up for about 5-10 seconds. Then the leds operate correctly, with a few (seemingly random) flashes of all leds on. Then it becomes rock stable after 10-30seconds. I notice that the effect is more dramatic if the computer has been sitting off for a while vs. turning it off and on.

I'm no expert, but it feels to me that this is either, normal cpu cylcing, or voltages becoming stable/capacitors charging. It does not feel like an intermittent connection because it doesn't last more that 30 seconds max.

Any thoughts?

Geoff Harrison 06-18-2008 12:38 PM

Does that happen when the halt/run switch is in the halt mode?

With mine, if I power up with the switch set to halt, the lights are instantly stable.


bugman 06-18-2008 12:39 PM

Yes, it happens when started in the halt mode. Do you expereince any delay at all when powering up?

Geoff Harrison 06-18-2008 12:44 PM

No, no delay at all. I'm not using the switching power supplies, but I doubt there would be any difference. When I power up there's no discernible delay before the the lights show whatever the switches are set to.


bugman 06-18-2008 01:38 PM

Any ideas where I should start to look for a problem? Some of the ICs were difficult to insert, and some of the leads had oxidation on them. I was thinking of starting by re-seating some of them.

Geoff Harrison 06-18-2008 02:47 PM


Originally Posted by bugman (Post 1402)
I was thinking of starting by re-seating some of them.

That's where I would start. Also, make sure your power supplies are not taking a while to stabilize, but that's a long shot. It might be instructive to pull the CPU chip and power it up. If the front panel is immediately stable then something is not halting the CPU on start up. If it isn't stable when the CPU isn't there then perhaps the front panel itself is flaky. You should be able to examine and modify memory from the front panel even without the CPU.

Edit: Well, maybe not. I checked that the front panel worked without the CPU before posting that and it worked fine, then I checked it again after and it doesn't work, so take that statement with a grain of salt. I'll try it again and let you know what I find.


Geoff Harrison 06-18-2008 03:08 PM

Well, I guess I don't know what I'm talking about. I can't get the front panel to do anything without the CPU now, so forget what I said.


bugman 06-18-2008 03:09 PM

Thanks, I'll do some troubleshooting tonight when I arrive home. I remember that my incoming 16 volts from the PSU is more like 14.7. I could also try tweaking it closer to the speced 16 volts.

I noticed that yours was over 16 volts.

Geoff Harrison 06-18-2008 07:53 PM

Ok, I knew I wasn't (completely) crazy. You can run the front panel without the CPU, but you have to pull BA (CPU pin 7) high. I removed my 6800 and connected CPU pin 7 to pin 4 (IRQ) which is tied high through a 3.3k resistor, and my front panel works fine.

Does anyone know why it worked for me once and then stopped? BA is driven through CMOS buffer PP, can a CMOS buffer whose input is floating drive its output high some times and low other times, at random?


bugman 06-18-2008 08:30 PM

I followed your lead in a different way. I plugged the 6800 cpu directly into the motherboard without the 32k expansion. All symptoms dissappeared, and it runs fine. So, its something with the cpu to expansion BRD connection, expansion BRD to motherboard connection, or some other problem with the expansion card. I need to leave home again, but I'll continue this evening. Any other thoughts based on this new info? I was carefull about seeing the pins making contact to the socket in the motherboard.

All times are GMT. The time now is 01:06 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.